x11-misc/alacarte: bump to 3.36.0, use py3 and python-single-r1
[gentoo.git] / x11-misc / dex / dex-0.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{3_6,3_7,3_8} )
7
8 inherit python-r1
9
10 DESCRIPTION="DesktopEntry eXecution - tool to manage and launch autostart entries"
11 HOMEPAGE="http://e-jc.de/"
12 SRC_URI="https://github.com/jceb/dex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17
18 IUSE="doc"
19
20 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21
22 RDEPEND="${PYTHON_DEPS}"
23 DEPEND="${RDEPEND}
24         doc? ( dev-python/sphinx )"
25
26 src_compile() {
27         # Makefile is for creating man page only
28         use doc && emake
29 }
30
31 src_install() {
32         dobin dex
33         python_replicate_script "${ED}/usr/bin/dex"
34         dodoc CHANGELOG.md README.rst
35         use doc && doman dex.1
36 }