x11-misc/mate-notification-daemon: Stabilize 1.22.1 for amd64,x86
[gentoo.git] / x11-misc / bbmail / bbmail-0.9.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="blackbox mail notification"
9 HOMEPAGE="https://sourceforge.net/projects/bbtools"
10 SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="amd64 ppc x86"
15 IUSE=""
16
17 RDEPEND="
18         dev-lang/perl
19         x11-wm/blackbox
20         x11-libs/libX11
21         x11-libs/libXext"
22 DEPEND="${RDEPEND}
23         x11-base/xorg-proto"
24
25 PATCHES=(
26         "${FILESDIR}"/${P}-gcc4.3.patch
27         "${FILESDIR}"/${P}-gcc4.4.patch
28         "${FILESDIR}"/${P}-shebang.patch
29 )
30
31 src_prepare() {
32         default
33         eautoreconf
34 }
35
36 src_install() {
37         default
38         dobin scripts/bbmailparsefm.pl
39 }