dev-python/routes: keyworded 2.4.1-r1 for ia64, bug #717946
[gentoo.git] / x11-misc / barrier / barrier-2.3.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit desktop xdg cmake
7
8 DESCRIPTION="Share a mouse and keyboard between computers (fork of Synergy)"
9 HOMEPAGE="https://github.com/debauchee/barrier"
10 SRC_URI="https://github.com/debauchee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE="gui libressl"
16
17 RDEPEND="
18         net-misc/curl
19         x11-libs/libICE
20         x11-libs/libSM
21         x11-libs/libX11
22         x11-libs/libXext
23         x11-libs/libXi
24         x11-libs/libXinerama
25         x11-libs/libXrandr
26         x11-libs/libXtst
27         gui? (
28                 dev-qt/qtcore:5
29                 dev-qt/qtgui:5
30                 dev-qt/qtnetwork:5
31                 dev-qt/qtwidgets:5
32                 net-dns/avahi[mdnsresponder-compat]
33         )
34         !libressl? ( dev-libs/openssl:0= )
35         libressl? ( dev-libs/libressl:0= )
36 "
37 DEPEND="
38         ${RDEPEND}
39         x11-base/xorg-proto
40 "
41
42 PATCHES=(
43         "${FILESDIR}"/${P}-inf-loop.patch
44         "${FILESDIR}"/${P}-no-avahi.patch
45         "${FILESDIR}"/${P}-pthread.patch
46         "${FILESDIR}"/${P}-qt-gui-only.patch
47 )
48
49 DOCS=(
50         ChangeLog
51         README.md
52         doc/${PN}.conf.example{,-advanced,-basic}
53 )
54
55 src_configure() {
56         local mycmakeargs=(
57                 -DBARRIER_BUILD_GUI=$(usex gui)
58                 -DBARRIER_BUILD_INSTALLER=OFF
59                 -DBARRIER_REVISION=00000000
60                 -DBARRIER_VERSION_STAGE=gentoo
61         )
62
63         cmake_src_configure
64 }
65
66 src_install() {
67         cmake_src_install
68         einstalldocs
69         doman doc/${PN}{c,s}.1
70
71         if use gui; then
72                 doicon -s scalable res/${PN}.svg
73                 doicon -s 256 res/${PN}.png
74                 make_desktop_entry ${PN} Barrier ${PN} Utility
75         fi
76 }