x11-misc/projecteur: drop old version
[gentoo.git] / x11-misc / albert / albert-0.14.22.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PLUGINS_HASH="5dc169ce81002b4472cc55c0341f6ac52fe130f5"
7 inherit cmake-utils gnome2-utils
8
9 DESCRIPTION="Desktop agnostic launcher"
10 HOMEPAGE="https://albertlauncher.github.io/"
11 # plugins is a git submodule. the hash is taken from the submodule reference in the ${PV} tag.
12 SRC_URI="https://github.com/albertlauncher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
13 https://github.com/albertlauncher/plugins/archive/${PLUGINS_HASH}.tar.gz -> ${P}-plugins.tar.gz"
14
15 LICENSE="GPL-3+"
16 SLOT="0"
17 KEYWORDS="amd64"
18 IUSE="debug"
19
20 RDEPEND="
21         dev-cpp/muParser
22         dev-qt/qtconcurrent:5
23         dev-qt/qtcore:5
24         dev-qt/qtdbus:5
25         dev-qt/qtdeclarative:5
26         dev-qt/qtgui:5
27         dev-qt/qtnetwork:5
28         dev-qt/qtsql:5[sqlite]
29         dev-qt/qtsvg:5
30         dev-qt/qtwidgets:5
31         dev-qt/qtx11extras:5
32         x11-libs/libX11
33         x11-libs/libXext
34 "
35 DEPEND="${RDEPEND}"
36
37 PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
38
39 src_prepare() {
40         mv "${WORKDIR}"/plugins-${PLUGINS_HASH}/* "${S}"/plugins/ || die
41
42         cmake-utils_src_prepare
43 }
44
45 src_configure() {
46         local mycmakeargs=(
47                 -DBUILD_DEBUG=$(usex debug)
48                 -DBUILD_PYTHON=OFF #plugin directory is empty causing build failure
49                 -DBUILD_VIRTUALBOX=OFF #plugin needs virtualbox installed to build, untested
50         )
51
52         cmake-utils_src_configure
53 }
54
55 pkg_postinst() {
56         gnome2_icon_cache_update
57 }
58
59 pkg_postrm() {
60         gnome2_icon_cache_update
61 }