x11-base/xcb-proto: Drop support for Python 2.7.
[gentoo.git] / x11-misc / 3ddesktop / 3ddesktop-0.2.9-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools eutils
6
7 DESCRIPTION="OpenGL virtual desktop switching"
8 HOMEPAGE="http://desk3d.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/desk3d/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ppc x86"
14
15 RDEPEND="
16         >=media-libs/freetype-2
17         media-libs/freeglut
18         media-libs/imlib2[X]
19         x11-libs/libX11
20         x11-libs/libXext
21         x11-libs/libXi
22         x11-libs/libXmu
23         x11-libs/libXt
24         x11-libs/libXxf86vm
25 "
26 DEPEND="
27         ${RDEPEND}
28         x11-base/xorg-proto
29 "
30
31 DOCS=( AUTHORS TODO ChangeLog README README.windowmanagers )
32
33 src_prepare() {
34         epatch \
35                 "${FILESDIR}"/${P}-gcc4.patch \
36                 "${FILESDIR}"/${P}-asneeded.patch \
37                 "${FILESDIR}"/${P}-missing-include.patch \
38                 "${FILESDIR}"/${P}-gl_init.patch
39
40         eautoreconf
41 }
42
43 pkg_postinst() {
44         echo
45         elog "This ebuild installed a configuration file called /etc/3ddesktop.conf"
46         elog "The default configuration makes a screenshot of the virtual desktops"
47         elog "every X seconds. This is non-optimal behavior."
48         elog
49         elog "To enable a more intelligent way of updating the virtual desktops,"
50         elog "execute the following:"
51         elog
52         elog "  echo \"AutoAcquire 0\" >> /etc/3ddesktop.conf"
53         elog
54         elog "This will cause 3ddesktop to update the virtual desktop snapshots"
55         elog "only when a 3d desktop switch is required."
56 }