app-editors/nano: update to EAPI=5 and use subslot w/ncurses #561310
[gentoo.git] / x11-libs / xcb-util-keysyms / xcb-util-keysyms-0.3.9-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 XORG_MODULE=/
8 XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
9 XORG_DOC=doc
10 XORG_MULTILIB=yes
11 inherit xorg-2
12
13 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-keysyms"
14 EGIT_HAS_SUBMODULES=yes
15
16 DESCRIPTION="X C-language Bindings sample implementations"
17 HOMEPAGE="http://xcb.freedesktop.org/"
18
19 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
20 IUSE="test"
21
22 RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
23         >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
24 DEPEND="${RDEPEND}
25         >=dev-util/gperf-3.0.1
26         test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
27
28 src_configure() {
29         XORG_CONFIGURE_OPTIONS=(
30                 $(use_with doc doxygen)
31         )
32
33         xorg-2_src_configure
34 }