x11-libs/libva: remove old
[gentoo.git] / x11-libs / xcb-util-cursor / xcb-util-cursor-0.1.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 XORG_MODULE=/
8 XORG_BASE_INDIVIDUAL_URI=https://xcb.freedesktop.org/dist
9 XORG_DOC=doc
10 XORG_MULTILIB=yes
11 inherit xorg-2
12
13 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-cursor"
14 EGIT_HAS_SUBMODULES=yes
15
16 DESCRIPTION="X C-language Bindings sample implementations"
17 HOMEPAGE="https://xcb.freedesktop.org/"
18
19 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
20 IUSE="test"
21
22 RDEPEND=">=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
23         >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
24         >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]
25         >=x11-proto/xcb-proto-1.8-r3:=[${MULTILIB_USEDEP}]
26         >=x11-proto/xproto-7.0.24:=[${MULTILIB_USEDEP}]"
27 DEPEND="${RDEPEND}
28         >=dev-util/gperf-3.0.1
29         test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
30
31 src_configure() {
32         XORG_CONFIGURE_OPTIONS=(
33                 $(use_with doc doxygen)
34         )
35
36         xorg-2_src_configure
37 }