x11-libs/pango: arm stable, bug #664108
[gentoo.git] / x11-libs / tslib / tslib-1.0-r3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils toolchain-funcs autotools multilib-minimal
7
8 PATCH_VER="5"
9 DESCRIPTION="Touchscreen Access Library"
10 HOMEPAGE="https://github.com/kergoth/tslib"
11 SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2
12         mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
13
14 LICENSE="LGPL-2"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
17 IUSE=""
18 #extras arctic2 collie corgi h3600 linear-h2200 mk712 ucb1x00"
19
20 DOCS=( AUTHORS NEWS README )
21
22 src_prepare() {
23         # patches come from buildroot + openembedded + suse
24         EPATCH_SUFFIX=patch epatch "${WORKDIR}"/patch
25         eautoreconf
26 }
27
28 multilib_src_configure() {
29         # compile everything. INSTALL_MASK= what you don't want.
30         ECONF_SOURCE=${S} \
31         econf \
32                 --enable-linear --enable-dejitter \
33                 --enable-variance --enable-pthres \
34                 --enable-input --enable-shared \
35                 --enable-arctic2 --enable-collie \
36                 --enable-corgi --enable-h3600 \
37                 --enable-linear-h2200 --enable-mk712 \
38                 --enable-ucb1x00 --disable-debug
39 }