Use https by default
[gentoo.git] / x11-libs / tslib / tslib-1.0-r3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit eutils toolchain-funcs autotools multilib-minimal
8
9 PATCH_VER="5"
10 DESCRIPTION="Touchscreen Access Library"
11 HOMEPAGE="https://github.com/kergoth/tslib"
12 SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2
13         mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
14
15 LICENSE="LGPL-2"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
18 IUSE=""
19 #extras arctic2 collie corgi h3600 linear-h2200 mk712 ucb1x00"
20
21 DOCS=( AUTHORS NEWS README )
22
23 src_prepare() {
24         # patches come from buildroot + openembedded + suse
25         EPATCH_SUFFIX=patch epatch "${WORKDIR}"/patch
26         eautoreconf
27 }
28
29 multilib_src_configure() {
30         # compile everything. INSTALL_MASK= what you don't want.
31         ECONF_SOURCE=${S} \
32         econf \
33                 --enable-linear --enable-dejitter \
34                 --enable-variance --enable-pthres \
35                 --enable-input --enable-shared \
36                 --enable-arctic2 --enable-collie \
37                 --enable-corgi --enable-h3600 \
38                 --enable-linear-h2200 --enable-mk712 \
39                 --enable-ucb1x00 --disable-debug
40 }