net-proxy/dnsproxy: remove old version
[gentoo.git] / x11-libs / libyui-ncurses / libyui-ncurses-2.46.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit cmake-utils
8
9 DESCRIPTION="UI abstraction library - ncurses plugin"
10 HOMEPAGE="https://github.com/libyui/libyui-ncurses"
11 SRC_URI="https://github.com/libyui/${PN}/archive/${PN}/master/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0/6"
15 KEYWORDS="~amd64 ~x86"
16
17 IUSE="static-libs"
18
19 RDEPEND="sys-libs/ncurses
20         x11-libs/libyui:${SLOT}
21 "
22 # Only Boost headers are needed
23 DEPEND="${RDEPEND}
24         dev-libs/boost"
25
26 PATCHES=( "${FILESDIR}/${P}-tinfo.patch" )
27
28 S="${WORKDIR}/${PN}-${PN}-master-${PV}"
29
30 src_prepare() {
31         cp "${EPREFIX}/usr/share/libyui/buildtools/CMakeLists.common" CMakeLists.txt || die
32
33         # TODO: set proper docs deps and USE flag for building them
34         sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
35         sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
36
37         cmake-utils_src_prepare
38 }
39
40 src_configure() {
41         local mycmakeargs=(
42                 -DENABLE_EXAMPLES=OFF
43                 -DENABLE_WERROR=OFF
44                 -DDOC_DIR="${EPREFIX}/usr/share/doc/${P}"
45                 -DRESPECT_FLAGS=ON
46                 $(cmake-utils_use_enable static-libs STATIC)
47         )
48         cmake-utils_src_configure
49 }