dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-libs / libva-vdpau-driver / libva-vdpau-driver-0.7.4-r5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools multilib-minimal
7
8 DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
9 HOMEPAGE="https://www.freedesktop.org/wiki/Software/vaapi"
10 SRC_URI="https://www.freedesktop.org/software/vaapi/releases/libva-vdpau-driver/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 arm64 x86"
15 IUSE="debug opengl"
16
17 RDEPEND=">=x11-libs/libva-1.2.1-r1:=[X,opengl?,${MULTILIB_USEDEP}]
18         opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
19         >=x11-libs/libvdpau-0.8[${MULTILIB_USEDEP}]"
20
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 DOCS=( NEWS README AUTHORS )
25
26 PATCHES=(
27         "${FILESDIR}"/${P}-glext-missing-definition.patch
28         "${FILESDIR}"/${P}-VAEncH264VUIBufferType.patch
29         "${FILESDIR}"/${P}-libvdpau-0.8.patch
30         "${FILESDIR}"/${P}-sigfpe-crash.patch
31         "${FILESDIR}"/${P}-include-linux-videodev2.h.patch
32 )
33
34 src_prepare() {
35         default
36         sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
37         eautoreconf
38 }
39
40 multilib_src_configure() {
41         local myeconfargs=(
42                 $(use_enable debug)
43                 $(use_enable opengl glx)
44         )
45
46         ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
47 }