dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / x11-libs / libva-intel-driver / libva-intel-driver-2.3.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MY_PN="intel-vaapi-driver"
7 if [[ ${PV} = *9999* ]] ; then # Live ebuild
8         inherit git-r3
9         EGIT_BRANCH=master
10         EGIT_REPO_URI="https://github.com/intel/intel-vaapi-driver"
11 fi
12 AUTOTOOLS_AUTORECONF="yes"
13 inherit autotools-multilib
14
15 DESCRIPTION="HW video decode support for Intel integrated graphics"
16 HOMEPAGE="https://github.com/intel/intel-vaapi-driver"
17 if [[ ${PV} != *9999* ]] ; then
18         SRC_URI="https://github.com/intel/${MY_PN}/releases/download/${PV}/${MY_PN}-${PV}.tar.bz2"
19         S="${WORKDIR}/${MY_PN}-${PV}"
20         KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
21 fi
22
23 LICENSE="MIT"
24 SLOT="0"
25 IUSE="wayland X"
26
27 RDEPEND="
28         >=x11-libs/libdrm-2.4.52[video_cards_intel,${MULTILIB_USEDEP}]
29         >=x11-libs/libva-2.4.0:=[X?,wayland?,drm,${MULTILIB_USEDEP}]
30         wayland? (
31                 >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}]
32                 >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}]
33         )
34 "
35 DEPEND="${RDEPEND}
36         virtual/pkgconfig
37 "
38
39 DOCS=( AUTHORS NEWS README )
40 AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
41
42 src_prepare() {
43         sed -e 's/intel-gen4asm/\0diSaBlEd/g' -i configure.ac || die
44         autotools-multilib_src_prepare
45 }
46
47 multilib_src_configure() {
48         local myeconfargs=(
49                 $(use_enable wayland)
50                 $(use_enable X x11)
51         )
52         autotools-utils_src_configure
53 }