www-client/chromium: stable channel bump to 79.0.3945.130
[gentoo.git] / x11-libs / libtinynotify-cli / libtinynotify-cli-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGIT_REPO_URI="https://github.com/mgorny/tinynotify-send.git"
7 inherit autotools git-r3
8
9 MY_P=tinynotify-send-${PV}
10 DESCRIPTION="Common CLI routines for tinynotify-send & sw-notify-send"
11 HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
12 SRC_URI=""
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE="doc static-libs"
18
19 RDEPEND="x11-libs/libtinynotify:0="
20 DEPEND="${RDEPEND}
21         >=dev-util/gtk-doc-1.18
22         virtual/pkgconfig
23         doc? ( dev-util/gtk-doc )"
24
25 src_prepare() {
26         default
27         eautoreconf
28 }
29
30 src_configure() {
31         local myconf=(
32                 $(use_enable doc gtk-doc)
33                 $(use_enable static-libs static)
34                 --disable-regular
35                 --disable-system-wide
36         )
37
38         econf "${myconf[@]}"
39 }
40
41 src_install() {
42         default
43         find "${D}" -name '*.la' -delete || die
44 }