Use https by default
[gentoo.git] / x11-libs / libfm / libfm-0.1.17-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit autotools eutils fdo-mime
8
9 DESCRIPTION="A library for file management"
10 HOMEPAGE="http://pcmanfm.sourceforge.net/"
11 SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
12
13 KEYWORDS="~alpha amd64 arm ppc x86 ~amd64-linux ~x86-linux"
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE="debug examples udev"
17
18 COMMON_DEPEND=">=dev-libs/glib-2.18:2
19         >=x11-libs/gtk+-2.16:2
20         udev? ( dev-libs/dbus-glib )
21         >=lxde-base/menu-cache-0.3.2"
22 RDEPEND="${COMMON_DEPEND}
23         x11-misc/shared-mime-info
24         udev? ( sys-fs/udisks:0 )"
25 DEPEND="${COMMON_DEPEND}
26         dev-util/gtk-doc-am
27         >=dev-util/intltool-0.40
28         virtual/pkgconfig
29         sys-devel/gettext"
30
31 src_prepare() {
32         sed -ie '/SUBDIRS=/s#docs##' "${S}"/Makefile.am || die "sed failed"
33         sed -i -e '/^[[:space:]]*docs/d' -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
34                 configure.ac || die "sed failed"
35         #Remove -Werror for automake-1.12. Bug #421101
36         sed -i "s:-Werror::" configure.ac || die
37         # Bug 409939
38         epatch "${FILESDIR}"/${P}-ssp-fix.patch
39         eautoreconf
40 }
41
42 src_configure() {
43         econf \
44                 --sysconfdir="${EPREFIX}/etc" \
45                 --disable-dependency-tracking \
46                 --disable-static \
47                 $(use_enable udev udisks) \
48                 $(use_enable examples demo) \
49                 $(use_enable debug) \
50                 # Documentation fails to build at the moment
51                 # $(use_enable doc gtk-doc) \
52                 # $(use_enable doc gtk-doc-html) \
53                 --with-html-dir=/usr/share/doc/${PF}/html
54 }
55
56 src_install() {
57         default
58         find "${D}" -name '*.la' -exec rm -f '{}' +
59 }
60
61 pkg_postinst() {
62         fdo-mime_mime_database_update
63 }
64
65 pkg_postrm() {
66         fdo-mime_mime_database_update
67 }