Use https by default
[gentoo.git] / x11-libs / libdockapp / libdockapp-0.7.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools font
7
8 DESCRIPTION="Window Maker Dock Applet Library"
9 HOMEPAGE="http://windowmaker.org/dockapps/?name=wmclock"
10 # Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
11 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
12
13 LICENSE="MIT public-domain"
14 SLOT="0/3"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
16 # Required for font eclass
17 IUSE="+X"
18 REQUIRED_USE="X"
19
20 RDEPEND="x11-libs/libX11
21         x11-libs/libXt
22         x11-libs/libXext
23         x11-libs/libXpm"
24 DEPEND="${RDEPEND}
25         x11-proto/xproto"
26
27 FONT_S=${S}/fonts
28 FONT_SUFFIX="gz"
29 DOCS="README ChangeLog NEWS AUTHORS"
30
31 src_prepare()
32 {
33         eautoreconf
34 }
35
36 src_configure()
37 {
38         # Font installation handled by font eclass
39         econf --without-font --without-examples
40 }
41
42 src_install()
43 {
44         emake DESTDIR="${D}" install
45         font_src_install
46 }