x11-libs/gtk+: x86 stable wrt bug #716868
[gentoo.git] / x11-libs / libGLw / libGLw-8.0.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_P=glw-"${PV}"
7
8 DESCRIPTION="Mesa GLw library"
9 HOMEPAGE="http://mesa3d.sourceforge.net/"
10 SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/glw/${MY_P}.tar.bz2"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
15 IUSE="+motif"
16
17 RDEPEND="
18         x11-libs/libX11
19         x11-libs/libXt
20         x11-libs/motif:0
21         virtual/opengl"
22 DEPEND="${RDEPEND}"
23 BDEPEND="virtual/pkgconfig"
24
25 S="${WORKDIR}/${MY_P}"
26
27 PATCHES=( "${FILESDIR}"/${P}-gcc10-fno-common.patch )
28
29 src_configure() {
30         econf \
31                 --disable-static \
32                 --enable-motif
33 }
34
35 src_install() {
36         default
37
38         # no static archives
39         find "${D}" -name '*.la' -delete || die
40 }