kde-frameworks/networkmanager-qt: Drop 5.40.0 (r0)
[gentoo.git] / x11-libs / gtkglarea / gtkglarea-2.0.1-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 GCONF_DEBUG="no"
7 GNOME_TARBALL_SUFFIX="bz2"
8
9 inherit gnome2
10
11 DESCRIPTION="OpenGL canvas and context provider for GTK+"
12 HOMEPAGE="http://www.mono-project.com/GtkGLArea"
13
14 LICENSE="LGPL-2+ GPL-2+" # examples are GPL-2+, library is LGPL-2+
15 SLOT="2"
16 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
17 IUSE="examples"
18
19 RDEPEND=">=x11-libs/gtk+-2.0.3:2
20         virtual/opengl"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 src_prepare() {
25         # Do not build examples
26         sed "s:\(SUBDIRS.*\)examples:\1:" -i Makefile.am Makefile.in || die "sed 1 failed"
27         # -lGLU is only needed for building examples. Avoid autoreconf.
28         sed -e 's: -lGLU::' -i configure || die "sed 2 failed"
29
30         gnome2_src_prepare
31 }
32
33 src_configure() {
34         gnome2_src_configure --disable-static
35 }
36
37 src_install() {
38         DOCS="AUTHORS ChangeLog NEWS README* docs/*.txt"
39         gnome2_src_install
40
41         if use examples; then
42                 cd "${S}"/examples
43                 insinto /usr/share/doc/${PF}/examples
44                 doins *.c *.h *.lwo README || die "doins failed"
45         fi
46 }