bf0f4ec8c4be11ebc334ad4b62e7e180916afcdd
[gentoo.git] / x11-libs / goffice / goffice-0.10.41.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 GNOME2_LA_PUNT="yes"
6
7 inherit gnome2
8
9 DESCRIPTION="A library of document-centric objects and utilities"
10 HOMEPAGE="https://git.gnome.org/browse/goffice/"
11
12 LICENSE="GPL-2"
13 SLOT="0.10"
14 KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
15 IUSE="+introspection"
16
17 # FIXME: add lasem to tree
18 RDEPEND="
19         >=app-text/libspectre-0.2.6:=
20         >=dev-libs/glib-2.38.0:2
21         dev-libs/libxslt
22         >=gnome-base/librsvg-2.22:2
23         >=gnome-extra/libgsf-1.14.24:=[introspection?]
24         >=dev-libs/libxml2-2.4.12:2
25         >=x11-libs/pango-1.24:=
26         >=x11-libs/cairo-1.10:=[svg]
27         x11-libs/libXext:=
28         x11-libs/libXrender:=
29         >=x11-libs/gdk-pixbuf-2.22:2
30         >=x11-libs/gtk+-3.20:3
31         introspection? (
32                 >=dev-libs/gobject-introspection-1:=
33                 >=gnome-extra/libgsf-1.14.23:= )
34 "
35 DEPEND="${RDEPEND}
36         dev-lang/perl
37         virtual/perl-Getopt-Long
38         virtual/perl-IO-Compress
39         virtual/perl-Compress-Raw-Zlib
40         dev-util/glib-utils
41         >=dev-util/gtk-doc-am-1.12
42         >=dev-util/intltool-0.35
43         virtual/pkgconfig
44 "
45
46 src_configure() {
47         gnome2_src_configure \
48                 --without-lasem \
49                 --with-gtk \
50                 --with-config-backend=gsettings \
51                 $(use_enable introspection)
52 }