Merge remote-tracking branch 'remotes/gktrk/lastpass-cli-cert-fixes'
[gentoo.git] / x11-libs / flowcanvas / flowcanvas-0.7.1-r2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8 PYTHON_REQ_USE='threads(+)'
9
10 inherit waf-utils python-any-r1 eutils flag-o-matic
11
12 DESCRIPTION="Gtkmm/Gnomecanvasmm widget for boxes and lines environments"
13 HOMEPAGE="http://wiki.drobilla.net/FlowCanvas"
14 SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="amd64 x86"
19 IUSE="debug doc"
20
21 RDEPEND="dev-libs/boost
22         >=dev-cpp/gtkmm-2.4:2.4
23         >=dev-cpp/libgnomecanvasmm-2.6:2.6
24         media-gfx/graphviz"
25 DEPEND="${RDEPEND}
26         ${PYTHON_DEPS}
27         virtual/pkgconfig
28         doc? ( app-doc/doxygen )"
29
30 DOCS=( AUTHORS README ChangeLog )
31
32 src_prepare() {
33         epatch "${FILESDIR}/ldconfig2.patch"
34         has_version '>=media-gfx/graphviz-2.34' && epatch "${FILESDIR}/gv234.patch"
35         append-cxxflags -std=c++11
36 }
37
38 src_configure() {
39         waf-utils_src_configure \
40                 --htmldir=/usr/share/doc/${PF}/html \
41                 $(use debug && echo "--debug") \
42                 $(use doc && echo "--doc")
43 }