Merge remote-tracking branch 'github/pr/1997'
[gentoo.git] / x11-drivers / xf86-input-wacom / xf86-input-wacom-0.32.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit linux-info xorg-2
8
9 DESCRIPTION="Driver for Wacom tablets and drawing devices"
10 HOMEPAGE="http://linuxwacom.sourceforge.net/"
11 LICENSE="GPL-2"
12 EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
13 [[ ${PV} != 9999* ]] && \
14         SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
15
16 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
17 IUSE="debug"
18
19 # depend on libwacom for its udev rules, bug #389633
20 RDEPEND="dev-libs/libwacom
21         virtual/udev
22         >=x11-base/xorg-server-1.7
23         x11-libs/libX11
24         x11-libs/libXext
25         x11-libs/libXi
26         x11-libs/libXrandr
27         x11-libs/libXinerama"
28 DEPEND="${RDEPEND}
29         x11-proto/randrproto"
30
31 pkg_setup() {
32         linux-info_pkg_setup
33
34         XORG_CONFIGURE_OPTIONS=(
35                 $(use_enable debug)
36         )
37 }
38
39 src_install() {
40         xorg-2_src_install
41
42         rm -rf "${ED}"/usr/share/hal
43 }
44
45 pkg_pretend() {
46         linux-info_pkg_setup
47
48         if ! linux_config_exists \
49                         || ! linux_chkconfig_present TABLET_USB_WACOM \
50                         || ! linux_chkconfig_present INPUT_EVDEV; then
51                 echo
52                 ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
53                 ewarn "  Device Drivers --->"
54                 ewarn "    Input device support --->"
55                 ewarn "      <*>   Event interface"
56                 ewarn "      [*]   Tablets  --->"
57                 ewarn "        <*>   Wacom Intuos/Graphire tablet support (USB)"
58                 echo
59         fi
60 }