cfeb58c5e8864b33818aa19d5d770c766ff21b91
[gentoo.git] / x11-drivers / xf86-input-synaptics / xf86-input-synaptics-1.8.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit linux-info xorg-2
8
9 DESCRIPTION="Driver for Synaptics touchpads"
10 HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
11
12 KEYWORDS="amd64 arm ~mips ppc ~ppc64 x86"
13 IUSE="kernel_linux"
14
15 RDEPEND="kernel_linux? ( >=dev-libs/libevdev-0.4 )
16         >=x11-base/xorg-server-1.14
17         >=x11-libs/libXi-1.2
18         >=x11-libs/libXtst-1.1.0"
19 DEPEND="${RDEPEND}
20         >=sys-kernel/linux-headers-2.6.37
21         >=x11-proto/inputproto-2.1.99.3
22         >=x11-proto/recordproto-1.14"
23
24 DOCS=( "README" )
25
26 pkg_pretend() {
27         linux-info_pkg_setup
28         # Just a friendly warning
29         if ! linux_config_exists \
30                         || ! linux_chkconfig_present INPUT_EVDEV; then
31                 echo
32                 ewarn "This driver requires event interface support in your kernel"
33                 ewarn "  Device Drivers --->"
34                 ewarn "    Input device support --->"
35                 ewarn "      <*>     Event interface"
36                 echo
37         fi
38 }