x11-base/xorg-drivers-1.20: ppc64 stable, bug 669588
[gentoo.git] / x11-base / xorg-drivers / xorg-drivers-1.20.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Meta package containing deps on all xorg drivers"
7 HOMEPAGE="https://www.gentoo.org/"
8 SRC_URI=""
9
10 LICENSE="metapackage"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
13
14 IUSE_INPUT_DEVICES="
15         input_devices_elographics
16         input_devices_evdev
17         input_devices_joystick
18         input_devices_keyboard
19         input_devices_libinput
20         input_devices_mouse
21         input_devices_tslib
22         input_devices_vmmouse
23         input_devices_void
24         input_devices_synaptics
25         input_devices_wacom
26 "
27 IUSE_VIDEO_CARDS="
28         video_cards_amdgpu
29         video_cards_ast
30         video_cards_dummy
31         video_cards_fbdev
32         video_cards_freedreno
33         video_cards_geode
34         video_cards_glint
35         video_cards_i915
36         video_cards_i965
37         video_cards_intel
38         video_cards_mga
39         video_cards_nouveau
40         video_cards_nv
41         video_cards_omap
42         video_cards_qxl
43         video_cards_r128
44         video_cards_radeon
45         video_cards_radeonsi
46         video_cards_siliconmotion
47         video_cards_tdfx
48         video_cards_tegra
49         video_cards_vc4
50         video_cards_vesa
51         video_cards_via
52         video_cards_virtualbox
53         video_cards_vmware
54         video_cards_voodoo
55         video_cards_nvidia
56 "
57
58 IUSE="${IUSE_VIDEO_CARDS} ${IUSE_INPUT_DEVICES}"
59
60 PDEPEND="
61         input_devices_elographics? ( x11-drivers/xf86-input-elographics )
62         input_devices_evdev?       ( >=x11-drivers/xf86-input-evdev-2.10.6 )
63         input_devices_joystick?    ( >=x11-drivers/xf86-input-joystick-1.6.3 )
64         input_devices_keyboard?    ( x11-drivers/xf86-input-keyboard )
65         input_devices_libinput?    ( >=x11-drivers/xf86-input-libinput-0.27.1 )
66         input_devices_mouse?       ( >=x11-drivers/xf86-input-mouse-1.9.3 )
67         input_devices_tslib?       ( x11-drivers/xf86-input-tslib )
68         input_devices_vmmouse?     ( x11-drivers/xf86-input-vmmouse )
69         input_devices_void?        ( x11-drivers/xf86-input-void )
70         input_devices_synaptics?   ( x11-drivers/xf86-input-synaptics )
71         input_devices_wacom?       ( >=x11-drivers/xf86-input-wacom-0.36.0-r2 )
72
73         video_cards_amdgpu?        ( >=x11-drivers/xf86-video-amdgpu-18.0.1 )
74         video_cards_ast?           ( x11-drivers/xf86-video-ast )
75         video_cards_dummy?         ( x11-drivers/xf86-video-dummy )
76         video_cards_fbdev?         ( >=x11-drivers/xf86-video-fbdev-0.5.0 )
77         video_cards_freedreno?     ( >=x11-base/xorg-server-${PV}[glamor] )
78         video_cards_geode?         ( x11-drivers/xf86-video-geode )
79         video_cards_glint?         ( >=x11-drivers/xf86-video-glint-1.2.9 )
80         video_cards_i915?          ( x11-drivers/xf86-video-intel )
81         video_cards_i965?          ( >=x11-base/xorg-server-${PV}[glamor] )
82         video_cards_intel?         ( !video_cards_i965? ( >=x11-drivers/xf86-video-intel-2.99.917_p20180214-r1 ) )
83         video_cards_mga?           ( >=x11-drivers/xf86-video-mga-1.6.5 )
84         video_cards_nouveau?       ( >=x11-drivers/xf86-video-nouveau-1.0.13 )
85         video_cards_nv?            ( >=x11-drivers/xf86-video-nv-2.1.21 )
86         video_cards_omap?          ( >=x11-drivers/xf86-video-omap-0.4.5 )
87         video_cards_qxl?           ( x11-drivers/xf86-video-qxl )
88         video_cards_nvidia?        ( x11-drivers/nvidia-drivers )
89         video_cards_r128?          ( >=x11-drivers/xf86-video-r128-6.10.2 )
90         video_cards_radeon?        ( >=x11-drivers/xf86-video-ati-18.0.1-r1 )
91         video_cards_radeonsi?      ( >=x11-drivers/xf86-video-ati-18.0.1-r1[glamor] )
92         video_cards_siliconmotion? ( >=x11-drivers/xf86-video-siliconmotion-1.7.9 )
93         video_cards_tdfx?          ( >=x11-drivers/xf86-video-tdfx-1.4.7 )
94         video_cards_tegra?         ( >=x11-base/xorg-server-${PV}[glamor] )
95         video_cards_vc4?           ( >=x11-base/xorg-server-${PV}[glamor] )
96         video_cards_vesa?          ( x11-drivers/xf86-video-vesa )
97         video_cards_via?           ( x11-drivers/xf86-video-openchrome )
98         video_cards_virtualbox?    ( x11-drivers/xf86-video-vboxvideo )
99         video_cards_vmware?        ( >=x11-drivers/xf86-video-vmware-13.3.0 )
100         video_cards_voodoo?        ( x11-drivers/xf86-video-voodoo )
101
102         !x11-drivers/xf86-input-citron
103         !x11-drivers/xf86-video-apm
104         !x11-drivers/xf86-video-ark
105         !x11-drivers/xf86-video-chips
106         !x11-drivers/xf86-video-cirrus
107         !x11-drivers/xf86-video-cyrix
108         !x11-drivers/xf86-video-i128
109         !x11-drivers/xf86-video-i740
110         !x11-drivers/xf86-video-impact
111         !x11-drivers/xf86-video-mach64
112         !x11-drivers/xf86-video-neomagic
113         !x11-drivers/xf86-video-newport
114         !x11-drivers/xf86-video-nsc
115         !x11-drivers/xf86-video-rendition
116         !x11-drivers/xf86-video-s3
117         !x11-drivers/xf86-video-s3virge
118         !x11-drivers/xf86-video-savage
119         !x11-drivers/xf86-video-sis
120         !x11-drivers/xf86-video-sisusb
121         !x11-drivers/xf86-video-sunbw2
122         !x11-drivers/xf86-video-suncg14
123         !x11-drivers/xf86-video-suncg3
124         !x11-drivers/xf86-video-suncg6
125         !x11-drivers/xf86-video-sunffb
126         !x11-drivers/xf86-video-sunleo
127         !x11-drivers/xf86-video-suntcx
128         !x11-drivers/xf86-video-tga
129         !x11-drivers/xf86-video-trident
130         !x11-drivers/xf86-video-tseng
131
132         !<x11-drivers/xf86-input-evdev-2.10.4
133 "