Use https by default
[gentoo.git] / x11-base / xorg-drivers / xorg-drivers-1.17.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="Meta package containing deps on all xorg drivers"
8 HOMEPAGE="https://www.gentoo.org/"
9 SRC_URI=""
10
11 LICENSE="metapackage"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
14
15 IUSE_INPUT_DEVICES="
16         input_devices_acecad
17         input_devices_aiptek
18         input_devices_elographics
19         input_devices_evdev
20         input_devices_fpit
21         input_devices_hyperpen
22         input_devices_joystick
23         input_devices_keyboard
24         input_devices_libinput
25         input_devices_mouse
26         input_devices_mutouch
27         input_devices_penmount
28         input_devices_tslib
29         input_devices_vmmouse
30         input_devices_void
31         input_devices_synaptics
32         input_devices_wacom
33 "
34 IUSE_VIDEO_CARDS="
35         video_cards_apm
36         video_cards_ast
37         video_cards_chips
38         video_cards_cirrus
39         video_cards_dummy
40         video_cards_epson
41         video_cards_fbdev
42         video_cards_freedreno
43         video_cards_geode
44         video_cards_glint
45         video_cards_i128
46         video_cards_i740
47         video_cards_intel
48         video_cards_mach64
49         video_cards_mga
50         video_cards_neomagic
51         video_cards_nouveau
52         video_cards_nv
53         video_cards_omap
54         video_cards_omapfb
55         video_cards_qxl
56         video_cards_r128
57         video_cards_radeon
58         video_cards_radeonsi
59         video_cards_rendition
60         video_cards_s3
61         video_cards_s3virge
62         video_cards_savage
63         video_cards_siliconmotion
64         video_cards_sisusb
65         video_cards_sunbw2
66         video_cards_suncg14
67         video_cards_suncg3
68         video_cards_suncg6
69         video_cards_sunffb
70         video_cards_sunleo
71         video_cards_suntcx
72         video_cards_tdfx
73         video_cards_tegra
74         video_cards_tga
75         video_cards_trident
76         video_cards_tseng
77         video_cards_vesa
78         video_cards_via
79         video_cards_virtualbox
80         video_cards_vmware
81         video_cards_voodoo
82         video_cards_fglrx
83         video_cards_nvidia
84 "
85
86 IUSE="${IUSE_VIDEO_CARDS} ${IUSE_INPUT_DEVICES}"
87
88 PDEPEND="
89         input_devices_acecad?      ( x11-drivers/xf86-input-acecad )
90         input_devices_aiptek?      ( x11-drivers/xf86-input-aiptek )
91         input_devices_elographics? ( x11-drivers/xf86-input-elographics )
92         input_devices_evdev?       ( x11-drivers/xf86-input-evdev )
93         input_devices_fpit?        ( x11-drivers/xf86-input-fpit )
94         input_devices_hyperpen?    ( x11-drivers/xf86-input-hyperpen )
95         input_devices_joystick?    ( x11-drivers/xf86-input-joystick )
96         input_devices_keyboard?    ( x11-drivers/xf86-input-keyboard )
97         input_devices_libinput?    ( x11-drivers/xf86-input-libinput )
98         input_devices_mouse?       ( x11-drivers/xf86-input-mouse )
99         input_devices_mutouch?     ( x11-drivers/xf86-input-mutouch )
100         input_devices_penmount?    ( x11-drivers/xf86-input-penmount )
101         input_devices_tslib?       ( x11-drivers/xf86-input-tslib )
102         input_devices_vmmouse?     ( x11-drivers/xf86-input-vmmouse )
103         input_devices_void?        ( x11-drivers/xf86-input-void )
104         input_devices_synaptics?   ( x11-drivers/xf86-input-synaptics )
105         input_devices_wacom?       ( x11-drivers/xf86-input-wacom )
106
107         video_cards_apm?           ( x11-drivers/xf86-video-apm )
108         video_cards_ast?           ( x11-drivers/xf86-video-ast )
109         video_cards_chips?         ( x11-drivers/xf86-video-chips )
110         video_cards_cirrus?        ( x11-drivers/xf86-video-cirrus )
111         video_cards_dummy?         ( x11-drivers/xf86-video-dummy )
112         video_cards_fbdev?         ( x11-drivers/xf86-video-fbdev )
113         video_cards_freedreno?     ( x11-drivers/xf86-video-freedreno )
114         video_cards_geode?         ( x11-drivers/xf86-video-geode )
115         video_cards_glint?         ( x11-drivers/xf86-video-glint )
116         video_cards_i128?          ( x11-drivers/xf86-video-i128 )
117         video_cards_i740?          ( x11-drivers/xf86-video-i740 )
118         video_cards_intel?         ( x11-drivers/xf86-video-intel )
119         video_cards_mach64?        ( x11-drivers/xf86-video-mach64 )
120         video_cards_mga?           ( x11-drivers/xf86-video-mga )
121         video_cards_neomagic?      ( x11-drivers/xf86-video-neomagic )
122         video_cards_nouveau?       ( x11-drivers/xf86-video-nouveau )
123         video_cards_nv?            ( x11-drivers/xf86-video-nv )
124         video_cards_omap?          ( x11-drivers/xf86-video-omap )
125         video_cards_omapfb?        ( x11-drivers/xf86-video-omapfb )
126         video_cards_qxl?           ( x11-drivers/xf86-video-qxl )
127         video_cards_nvidia?        ( x11-drivers/nvidia-drivers )
128         video_cards_fglrx?         ( x11-drivers/ati-drivers )
129         video_cards_r128?          ( x11-drivers/xf86-video-r128 )
130         video_cards_radeon?        ( x11-drivers/xf86-video-ati )
131         video_cards_radeonsi?      ( x11-drivers/xf86-video-ati[glamor] )
132         video_cards_rendition?     ( x11-drivers/xf86-video-rendition )
133         video_cards_s3?            ( x11-drivers/xf86-video-s3 )
134         video_cards_s3virge?       ( x11-drivers/xf86-video-s3virge )
135         video_cards_savage?        ( x11-drivers/xf86-video-savage )
136         video_cards_siliconmotion? ( x11-drivers/xf86-video-siliconmotion )
137         video_cards_sisusb?        ( x11-drivers/xf86-video-sisusb )
138         video_cards_suncg14?       ( x11-drivers/xf86-video-suncg14 )
139         video_cards_suncg3?        ( x11-drivers/xf86-video-suncg3 )
140         video_cards_suncg6?        ( x11-drivers/xf86-video-suncg6 )
141         video_cards_sunffb?        ( x11-drivers/xf86-video-sunffb )
142         video_cards_sunleo?        ( x11-drivers/xf86-video-sunleo )
143         video_cards_suntcx?        ( x11-drivers/xf86-video-suntcx )
144         video_cards_tdfx?          ( x11-drivers/xf86-video-tdfx )
145         video_cards_tegra?         ( x11-drivers/xf86-video-opentegra )
146         video_cards_tga?           ( x11-drivers/xf86-video-tga )
147         video_cards_trident?       ( x11-drivers/xf86-video-trident )
148         video_cards_tseng?         ( x11-drivers/xf86-video-tseng )
149         video_cards_vesa?          ( x11-drivers/xf86-video-vesa )
150         video_cards_via?           ( x11-drivers/xf86-video-openchrome )
151         video_cards_virtualbox?    ( x11-drivers/xf86-video-virtualbox )
152         video_cards_vmware?        ( x11-drivers/xf86-video-vmware )
153         video_cards_voodoo?        ( x11-drivers/xf86-video-voodoo )
154
155         !x11-drivers/xf86-input-citron
156         !x11-drivers/xf86-video-cyrix
157         !x11-drivers/xf86-video-impact
158         !x11-drivers/xf86-video-nsc
159         !x11-drivers/xf86-video-sunbw2
160         !<=x11-drivers/xf86-video-ark-0.7.5
161         !<=x11-drivers/xf86-video-newport-0.2.4
162         !<=x11-drivers/xf86-video-sis-0.10.7
163         !<=x11-drivers/xf86-video-v4l-0.2.0
164 "