x11-apps/viewres: Drop old versions
[gentoo.git] / x11-apps / xwininfo / xwininfo-1.1.4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit xorg-2 flag-o-matic
7
8 DESCRIPTION="window information utility for X"
9
10 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris ~x86-winnt"
11 IUSE=""
12
13 RDEPEND=">=x11-libs/libxcb-1.6"
14 DEPEND="${RDEPEND}
15         x11-base/xorg-proto
16         x11-libs/libX11"
17
18 pkg_setup() {
19         # interix has a _very_ old iconv in libc, however, including
20         # iconv.h redefines those symbols to libiconv_*, which then
21         # are unresolved, as the configure check is old and dumb.
22         [[ ${CHOST} == *-interix* || ${CHOST} == *-solaris* ]] &&
23                 append-libs -liconv
24 }