dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / x11-apps / xwarppointer / xwarppointer-1-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Program to move the mouse cursor"
9 HOMEPAGE="http://www.ishiboo.com/~nirva/Projects/xwarppointer/"
10 SRC_URI="http://www.ishiboo.com/~nirva/Projects/xwarppointer/${PN}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15
16 DEPEND="x11-libs/libX11"
17 RDEPEND="${DEPEND}"
18
19 S="${WORKDIR}/${PN}"
20
21 src_prepare() {
22         sed -i Makefile \
23                 -e 's|^X11HOME=.*|X11HOME=/usr/X11R6|' \
24                 -e 's|^CFLAGS=|CFLAGS+=|' \
25                 -e 's| -o | $(LDFLAGS)&|' \
26                 || die 'setting X11HOME failed'
27 }
28
29 src_compile() {
30         emake CC="$(tc-getCC)"
31 }
32
33 src_install() {
34         dobin "${PN}"
35         dodoc README
36 }