x11-apps/xbacklight: Drop old versions
[gentoo.git] / x11-apps / xsm / xsm-1.0.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit xorg-2
7
8 DESCRIPTION="X Session Manager"
9 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
10 IUSE="rsh"
11 RDEPEND="x11-libs/libXaw
12         x11-libs/libX11
13         x11-libs/libXt
14         x11-libs/libICE
15         x11-libs/libSM
16         rsh? ( net-misc/netkit-rsh )"
17 DEPEND="${RDEPEND}"
18
19 pkg_setup() {
20         # (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
21         local XSMPATH="${EROOT}usr/$(get_libdir)/X11/xsm"
22         if [[ -L ${XSMPATH} ]]; then
23                 einfo "Removing symlink ${XSMPATH}"
24                 rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
25         fi
26         xorg-2_pkg_setup
27 }
28
29 src_configure() {
30         XORG_CONFIGURE_OPTIONS="$(use_with rsh rsh /usr/bin/rsh)"
31         xorg-2_src_configure
32 }