x11-apps/xinit: Fix postinstall message
[gentoo.git] / x11-apps / xinput_calibrator / xinput_calibrator-0.7.5-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools-utils flag-o-matic
6
7 DESCRIPTION="A generic touchscreen calibration program for X.Org"
8 HOMEPAGE="https://www.freedesktop.org/wiki/Software/xinput_calibrator"
9 SRC_URI="https://github.com/downloads/tias/${PN}/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="amd64 arm ~arm64 x86"
14 IUSE="gtk"
15
16 RDEPEND="x11-libs/libX11
17         x11-libs/libXext
18         x11-libs/libXi
19         x11-libs/libXrandr
20         gtk? ( dev-cpp/gtkmm:2.4 )"
21 DEPEND="${RDEPEND}
22         x11-base/xorg-proto"
23
24 src_configure() {
25         append-cxxflags -std=c++11 #566594
26
27         local myeconfargs=(
28                 --with-gui=$(use gtk && echo "gtkmm" || echo "x11")
29         )
30         autotools-utils_src_configure
31 }