x11-apps/fonttosfnt: x86 stable wrt bug #711560
[gentoo.git] / x11-apps / xauth / xauth-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit xorg-3
7
8 if [[ ${PV} == 9999* ]]; then
9         SRC_URI=""
10 else
11         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
12 fi
13
14 DESCRIPTION="X authority file utility"
15 IUSE="ipv6 test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="x11-libs/libX11
19         x11-libs/libXau
20         x11-libs/libXext
21         x11-libs/libXmu"
22 DEPEND="${RDEPEND}
23         x11-base/xorg-proto"
24 BDEPEND="test? ( dev-util/cmdtest )"
25
26 pkg_setup() {
27         XORG_CONFIGURE_OPTIONS=(
28                 $(use_enable ipv6)
29         )
30 }
31
32 src_test() {
33         addwrite /proc/self/comm
34         emake check
35 }