x11-apps/xinit: Fix postinstall message
[gentoo.git] / x11-apps / radeon-profile / radeon-profile-99999999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit qmake-utils
7
8 DESCRIPTION="Read current clocks of ATi/AMD Radeon cards"
9 HOMEPAGE="https://github.com/marazmista/radeon-profile"
10 if [[ "${PV}" == 99999999 ]] ; then
11         inherit git-r3
12         EGIT_REPO_URI="https://github.com/marazmista/radeon-profile.git"
13 else
14         SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64 ~x86"
16 fi
17 LICENSE="GPL-2"
18 SLOT="0"
19
20 IUSE=""
21
22 S="${WORKDIR}/${P}/${PN}"
23
24 RDEPEND="
25         dev-qt/qtcharts:5
26         dev-qt/qtcore:5
27         dev-qt/qtgui:5
28         dev-qt/qtnetwork:5
29         dev-qt/qtwidgets:5
30         x11-libs/libX11
31         x11-libs/libXrandr
32 "
33
34 DEPEND="
35         ${RDEPEND}
36         dev-qt/qtconcurrent:5
37         media-libs/mesa[X(+)]
38         x11-libs/libdrm
39 "
40
41 src_prepare() {
42         default
43         sed 's@TrayIcon;@@' -i extra/${PN}.desktop || die
44 }
45
46 src_configure() {
47         eqmake5
48 }
49
50 src_install() {
51         emake INSTALL_ROOT="${D}" install
52 }
53
54 pkg_postinst() {
55         elog "In order to run ${PN} as non-root user, the"
56         elog "  x11-apps/radeon-profile-daemon"
57         elog "package needs to be installed and the daemon must run."
58 }