Use https by default
[gentoo.git] / x11-apps / python-whiteboard / python-whiteboard-20101012.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="3"
6
7 inherit python multilib
8
9 SRC_URI="https://dev.gentoo.org/~lxnay/${PN}/${P}.tar.bz2"
10
11 KEYWORDS="~x86 ~amd64"
12 DESCRIPTION="Build and operate a electronic whiteboard Wiimote and IR Pen"
13 HOMEPAGE="https://github.com/pnegre/python-whiteboard"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="app-misc/cwiid[python]
20         dev-python/numpy
21         dev-python/pybluez
22         dev-python/PyQt4
23         dev-python/python-xlib"
24 DEPEND="${RDEPEND}"
25
26 src_install() {
27         emake DESTDIR="${D}" install || die "emake install failed"
28 }
29
30 pkg_postinst() {
31         python_mod_optimize "/usr/$(get_libdir)/${PN}"
32 }
33
34 pkg_postrm() {
35         python_mod_cleanup "/usr/$(get_libdir)/${PN}"
36 }