media-gfx/splash-themes-livecd: Merge gentoo-functions use fix
[gentoo.git] / www-servers / servefile / servefile-0.4.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Serve a single file via HTTP"
11 HOMEPAGE="http://seba-geek.de/stuff/servefile/"
12 SRC_URI="http://seba-geek.de/proj/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="ssl"
18
19 RDEPEND="
20         ssl? ( dev-python/pyopenssl )
21         sys-apps/grep
22         sys-apps/iproute2
23         sys-apps/net-tools
24         sys-apps/sed"
25
26 src_install() {
27         distutils-r1_src_install
28
29         dodoc ChangeLog || die
30         doman ${PN}.1 || die
31 }