268ad61c03c7bc1b4f53eb752668626b7c6d042c
[gentoo.git] / www-servers / servefile / servefile-0.4.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Serve a single file via HTTP"
10 HOMEPAGE="http://seba-geek.de/stuff/servefile/"
11 SRC_URI="http://seba-geek.de/proj/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="ssl"
17
18 RDEPEND="
19         ssl? ( dev-python/pyopenssl )
20         sys-apps/grep
21         sys-apps/iproute2
22         sys-apps/net-tools
23         sys-apps/sed"
24
25 src_install() {
26         distutils-r1_src_install
27
28         dodoc ChangeLog || die
29         doman ${PN}.1 || die
30 }