media-fonts/corefonts: Remove old
[gentoo.git] / www-servers / pound / pound-2.7d.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils
7
8 MY_P=${P/p/P}
9 DESCRIPTION="A http/https reverse-proxy and load-balancer"
10 HOMEPAGE="http://www.apsis.ch/pound/"
11 SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
16 IUSE=""
17
18 DEPEND="dev-libs/libpcre
19         dev-libs/openssl"
20 RDEPEND="${DEPEND}"
21
22 S=${WORKDIR}/${MY_P}
23
24 src_install() {
25         dodir /usr/sbin
26         cp "${S}"/pound "${D}"/usr/sbin/
27         cp "${S}"/poundctl "${D}"/usr/sbin/
28
29         doman pound.8
30         doman poundctl.8
31         dodoc README FAQ
32
33         dodir /etc/init.d
34         newinitd "${FILESDIR}"/pound.init-1.9 pound
35
36         insinto /etc
37         newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
38 }
39
40 pkg_postinst() {
41         elog "No demo-/sample-configfile is included in the distribution -"
42         elog "read the man-page for more info."
43         elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
44         echo
45         ewarn "You will have to upgrade you configuration file, if you are"
46         ewarn "upgrading from a version <= 2.0."
47         echo
48         ewarn "The 'WebDAV' config statement is no longer supported!"
49         ewarn "Please adjust your configuration, if necessary."
50         echo
51 }