www-servers/nginx-unit: Bump to version 0.17.0
[gentoo.git] / www-servers / fnord / fnord-1.11-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit flag-o-matic toolchain-funcs user
7
8 DESCRIPTION="Yet another small httpd"
9 HOMEPAGE="http://www.fefe.de/fnord/"
10 SRC_URI="http://www.fefe.de/fnord/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 hppa ppc sparc x86"
15 IUSE="auth"
16
17 DEPEND=""
18 RDEPEND="${DEPEND}
19         virtual/daemontools
20         sys-apps/ucspi-tcp"
21
22 DOCS=( TODO README README.auth SPEED CHANGES )
23 PATCHES=( "${FILESDIR}/${PN}"-1.10-gentoo.diff )
24
25 pkg_setup() {
26         enewgroup nofiles 200
27         enewuser fnord -1 -1 /etc/fnord nofiles
28         enewuser fnordlog -1 -1 /etc/fnord nofiles
29 }
30
31 src_compile() {
32         # Fix for bug #45716
33         use sparc && replace-sparc64-flags
34
35         use auth && append-flags -DAUTH
36
37         emake DIET="" CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
38 }
39
40 src_install() {
41         dobin fnord-conf fnord
42         einstalldocs
43 }