dev-python/packaging: ia64 stable wrt bug #711678
[gentoo.git] / www-servers / bozohttpd / bozohttpd-20170201.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="bozohttpd is a small and secure http server"
9 HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
10 SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
11
12 LICENSE="BSD-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE="libressl"
16
17 DEPEND="!libressl? ( dev-libs/openssl:0= )
18         libressl? ( dev-libs/libressl:= )"
19 RDEPEND="${DEPEND}
20         virtual/logger"
21
22 src_prepare() {
23         default
24         mv Makefile{.boot,} || die
25 }
26
27 src_compile() {
28         emake CC="$(tc-getCC)" OPT="${CFLAGS}"
29 }
30
31 src_install() {
32         dobin bozohttpd
33         doman bozohttpd.8
34
35         newconfd "${FILESDIR}"/${PN}.conffile   bozohttpd
36         newinitd "${FILESDIR}"/${PN}.initscript bozohttpd
37 }