dev-perl/Tie-Cache: EAPI6 + tests + QA
[gentoo.git] / www-servers / apache / apache-2.4.29.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # latest gentoo apache files
7 GENTOO_PATCHSTAMP="20160303"
8 GENTOO_DEVELOPER="polynomial-c"
9 GENTOO_PATCHNAME="gentoo-apache-2.4.18-r1"
10
11 # IUSE/USE_EXPAND magic
12 IUSE_MPMS_FORK="prefork"
13 IUSE_MPMS_THREAD="event worker"
14
15 # << obsolete modules:
16 # authn_default authz_default mem_cache
17 # mem_cache is replaced by cache_disk
18 # ?? buggy modules
19 # proxy_scgi: startup error: undefined symbol "ap_proxy_release_connection", no fix found
20 # >> added modules for reason:
21 # compat: compatibility with 2.2 access control
22 # authz_host: new module for access control
23 # authn_core: functionality provided by authn_alias in previous versions
24 # authz_core: new module, provides core authorization capabilities
25 # cache_disk: replacement for mem_cache
26 # lbmethod_byrequests: Split off from mod_proxy_balancer in 2.3
27 # lbmethod_bytraffic: Split off from mod_proxy_balancer in 2.3
28 # lbmethod_bybusyness: Split off from mod_proxy_balancer in 2.3
29 # lbmethod_heartbeat: Split off from mod_proxy_balancer in 2.3
30 # slotmem_shm: Slot-based shared memory provider (for lbmethod_byrequests).
31 # socache_shmcb: shared object cache provider. Default config with ssl needs it
32 # unixd: fixes startup error: Invalid command 'User'
33 IUSE_MODULES="access_compat actions alias asis auth_basic auth_digest
34 authn_alias authn_anon authn_core authn_dbd authn_dbm authn_file authz_core
35 authz_dbd authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex
36 cache cache_disk cache_socache cern_meta charset_lite cgi cgid dav dav_fs dav_lock
37 dbd deflate dir dumpio env expires ext_filter file_cache filter headers http2
38 ident imagemap include info lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness
39 lbmethod_heartbeat log_config log_forensic logio macro mime mime_magic negotiation
40 proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_html proxy_http proxy_scgi
41 proxy_fcgi  proxy_wstunnel rewrite ratelimit remoteip reqtimeout setenvif
42 slotmem_shm speling socache_shmcb status substitute unique_id userdir usertrack
43 unixd version vhost_alias watchdog xml2enc"
44 # The following are also in the source as of this version, but are not available
45 # for user selection:
46 # bucketeer case_filter case_filter_in echo http isapi optional_fn_export
47 # optional_fn_import optional_hook_export optional_hook_import
48
49 # inter-module dependencies
50 # TODO: this may still be incomplete
51 MODULE_DEPENDS="
52         dav_fs:dav
53         dav_lock:dav
54         deflate:filter
55         cache_disk:cache
56         ext_filter:filter
57         file_cache:cache
58         lbmethod_byrequests:proxy_balancer
59         lbmethod_byrequests:slotmem_shm
60         lbmethod_bytraffic:proxy_balancer
61         lbmethod_bybusyness:proxy_balancer
62         lbmethod_heartbeat:proxy_balancer
63         log_forensic:log_config
64         logio:log_config
65         cache_disk:cache
66         cache_socache:cache
67         mime_magic:mime
68         proxy_ajp:proxy
69         proxy_balancer:proxy
70         proxy_balancer:slotmem_shm
71         proxy_connect:proxy
72         proxy_ftp:proxy
73         proxy_html:proxy
74         proxy_html:xml2enc
75         proxy_http:proxy
76         proxy_scgi:proxy
77         proxy_fcgi:proxy
78         proxy_wstunnel:proxy
79         substitute:filter
80 "
81
82 # module<->define mappings
83 MODULE_DEFINES="
84         auth_digest:AUTH_DIGEST
85         authnz_ldap:AUTHNZ_LDAP
86         cache:CACHE
87         cache_disk:CACHE
88         cache_socache:CACHE
89         dav:DAV
90         dav_fs:DAV
91         dav_lock:DAV
92         file_cache:CACHE
93         http2:HTTP2
94         info:INFO
95         ldap:LDAP
96         proxy:PROXY
97         proxy_ajp:PROXY
98         proxy_balancer:PROXY
99         proxy_connect:PROXY
100         proxy_ftp:PROXY
101         proxy_html:PROXY
102         proxy_http:PROXY
103         proxy_fcgi:PROXY
104         proxy_scgi:PROXY
105         proxy_wstunnel:PROXY
106         socache_shmcb:SSL
107         ssl:SSL
108         status:STATUS
109         suexec:SUEXEC
110         userdir:USERDIR
111 "
112
113 # critical modules for the default config
114 MODULE_CRITICAL="
115         authn_core
116         authz_core
117         authz_host
118         dir
119         mime
120         unixd
121 "
122 inherit eutils apache-2 systemd toolchain-funcs
123
124 DESCRIPTION="The Apache Web Server"
125 HOMEPAGE="https://httpd.apache.org/"
126
127 # some helper scripts are Apache-1.1, thus both are here
128 LICENSE="Apache-2.0 Apache-1.1"
129 SLOT="2"
130 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
131
132 CDEPEND+="
133         apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )
134 "
135 DEPEND+="${CDEPEND}"
136 RDEPEND+="${CDEPEND}"
137
138 REQUIRED_USE="apache2_modules_http2? ( ssl )"
139
140 pkg_setup() {
141         # dependend critical modules which are not allowed in global scope due
142         # to USE flag conditionals (bug #499260)
143         use ssl && MODULE_CRITICAL+=" socache_shmcb"
144         use doc && MODULE_CRITICAL+=" alias negotiation setenvif"
145         apache-2_pkg_setup
146 }
147
148 src_configure() {
149         # Brain dead check.
150         tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
151
152         apache-2_src_configure
153 }
154
155 src_compile() {
156         if tc-is-cross-compiler; then
157                 # This header is the same across targets, so use the build compiler.
158                 pushd server >/dev/null
159                 emake gen_test_char
160                 tc-export_build_env BUILD_CC
161                 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
162                         gen_test_char.c -o gen_test_char $(apr-1-config --includes) || die
163                 popd >/dev/null
164         fi
165
166         default
167 }
168
169 src_install() {
170         apache-2_src_install
171         for i in /usr/bin/{htdigest,logresolve,htpasswd,htdbm,ab,httxt2dbm}; do
172                 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
173         done
174         for i in /usr/share/man/man8/{rotatelogs.8,htcacheclean.8}; do
175                 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
176         done
177         for i in /usr/share/man/man1/{logresolve.1,htdbm.1,htdigest.1,htpasswd.1,dbmmanage.1,ab.1}; do
178                 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
179         done
180         for i in /usr/sbin/{checkgid,fcgistarter,htcacheclean,rotatelogs}; do
181                 rm "${ED}/"$i || die "Failed to prune apache-tools bits"
182         done
183
184         # install apxs in /usr/bin (bug #502384) and put a symlink into the
185         # old location until all ebuilds and eclasses have been modified to
186         # use the new location.
187         local apxs="/usr/bin/apxs"
188         cp "${S}"/support/apxs "${ED%/}/${apxs}" || die "Failed to install apxs"
189         ln -s ../bin/apxs "${ED%/}/usr/sbin/apxs" || die
190         chmod 0755 "${ED%/}${apxs}" || die
191
192         # Note: wait for mod_systemd to be included in some forthcoming release,
193         # Then apache2.4.service can be used and systemd support controlled
194         # through --enable-systemd
195         systemd_newunit "${FILESDIR}/apache2.2-hardened.service" "apache2.service"
196         systemd_dotmpfilesd "${FILESDIR}/apache.conf"
197         #insinto /etc/apache2/modules.d
198         #doins "${FILESDIR}/00_systemd.conf"
199
200         # Install http2 module config
201         insinto /etc/apache2/modules.d
202         doins "${FILESDIR}"/41_mod_http2.conf
203 }
204
205 pkg_postinst() {
206         apache-2_pkg_postinst || die "apache-2_pkg_postinst failed"
207         # warnings that default config might not work out of the box
208         for mod in $MODULE_CRITICAL; do
209                 if ! use "apache2_modules_${mod}"; then
210                         echo
211                         ewarn "Warning: Critical module not installed!"
212                         ewarn "Modules 'authn_core', 'authz_core' and 'unixd'"
213                         ewarn "are highly recomended but might not be in the base profile yet."
214                         ewarn "Default config for ssl needs module 'socache_shmcb'."
215                         ewarn "Enabling the following flags is highly recommended:"
216                         for cmod in $MODULE_CRITICAL; do
217                                 use "apache2_modules_${cmod}" || \
218                                         ewarn "+ apache2_modules_${cmod}"
219                         done
220                         echo
221                         break
222                 fi
223         done
224         # warning for proxy_balancer and missing load balancing scheduler
225         if use apache2_modules_proxy_balancer; then
226                 local lbset=
227                 for mod in lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat; do
228                         if use "apache2_modules_${mod}"; then
229                                 lbset=1 && break
230                         fi
231                 done
232                 if [ ! ${lbset} ] ; then
233                         echo
234                         ewarn "Info: Missing load balancing scheduler algorithm module"
235                         ewarn "(They were split off from proxy_balancer in 2.3)"
236                         ewarn "In order to get the ability of load balancing, at least"
237                         ewarn "one of these modules has to be present:"
238                         ewarn "lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat"
239                         echo
240                 fi
241         fi
242 }