www-servers/apache: arm stable, bug #662894
[gentoo.git] / www-servers / apache / apache-2.4.27-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # latest gentoo apache files
7 GENTOO_PATCHSTAMP="20170918"
8 GENTOO_DEVELOPER="whissi"
9 GENTOO_PATCHNAME="gentoo-apache-2.4.27"
10
11 # IUSE/USE_EXPAND magic
12 IUSE_MPMS_FORK="prefork"
13 IUSE_MPMS_THREAD="event worker"
14
15 # << obsolete modules:
16 # authn_default authz_default mem_cache
17 # mem_cache is replaced by cache_disk
18 # ?? buggy modules
19 # proxy_scgi: startup error: undefined symbol "ap_proxy_release_connection", no fix found
20 # >> added modules for reason:
21 # compat: compatibility with 2.2 access control
22 # authz_host: new module for access control
23 # authn_core: functionality provided by authn_alias in previous versions
24 # authz_core: new module, provides core authorization capabilities
25 # cache_disk: replacement for mem_cache
26 # lbmethod_byrequests: Split off from mod_proxy_balancer in 2.3
27 # lbmethod_bytraffic: Split off from mod_proxy_balancer in 2.3
28 # lbmethod_bybusyness: Split off from mod_proxy_balancer in 2.3
29 # lbmethod_heartbeat: Split off from mod_proxy_balancer in 2.3
30 # slotmem_shm: Slot-based shared memory provider (for lbmethod_byrequests).
31 # socache_shmcb: shared object cache provider. Default config with ssl needs it
32 # unixd: fixes startup error: Invalid command 'User'
33 IUSE_MODULES="access_compat actions alias asis auth_basic auth_digest
34 authn_alias authn_anon authn_core authn_dbd authn_dbm authn_file authz_core
35 authz_dbd authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex
36 cache cache_disk cache_socache cern_meta charset_lite cgi cgid dav dav_fs dav_lock
37 dbd deflate dir dumpio env expires ext_filter file_cache filter headers http2
38 ident imagemap include info lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness
39 lbmethod_heartbeat log_config log_forensic logio macro mime mime_magic negotiation
40 proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_html proxy_http proxy_scgi
41 proxy_fcgi  proxy_wstunnel rewrite ratelimit remoteip reqtimeout setenvif
42 slotmem_shm speling socache_shmcb status substitute unique_id userdir usertrack
43 unixd version vhost_alias xml2enc"
44 # The following are also in the source as of this version, but are not available
45 # for user selection:
46 # bucketeer case_filter case_filter_in echo http isapi optional_fn_export
47 # optional_fn_import optional_hook_export optional_hook_import
48
49 # inter-module dependencies
50 # TODO: this may still be incomplete
51 MODULE_DEPENDS="
52         dav_fs:dav
53         dav_lock:dav
54         deflate:filter
55         cache_disk:cache
56         ext_filter:filter
57         file_cache:cache
58         lbmethod_byrequests:proxy_balancer
59         lbmethod_byrequests:slotmem_shm
60         lbmethod_bytraffic:proxy_balancer
61         lbmethod_bybusyness:proxy_balancer
62         lbmethod_heartbeat:proxy_balancer
63         log_forensic:log_config
64         logio:log_config
65         cache_disk:cache
66         cache_socache:cache
67         mime_magic:mime
68         proxy_ajp:proxy
69         proxy_balancer:proxy
70         proxy_balancer:slotmem_shm
71         proxy_connect:proxy
72         proxy_ftp:proxy
73         proxy_html:proxy
74         proxy_html:xml2enc
75         proxy_http:proxy
76         proxy_scgi:proxy
77         proxy_fcgi:proxy
78         proxy_wstunnel:proxy
79         substitute:filter
80 "
81
82 # module<->define mappings
83 MODULE_DEFINES="
84         auth_digest:AUTH_DIGEST
85         authnz_ldap:AUTHNZ_LDAP
86         cache:CACHE
87         cache_disk:CACHE
88         cache_socache:CACHE
89         dav:DAV
90         dav_fs:DAV
91         dav_lock:DAV
92         file_cache:CACHE
93         http2:HTTP2
94         info:INFO
95         ldap:LDAP
96         proxy:PROXY
97         proxy_ajp:PROXY
98         proxy_balancer:PROXY
99         proxy_connect:PROXY
100         proxy_ftp:PROXY
101         proxy_html:PROXY
102         proxy_http:PROXY
103         proxy_fcgi:PROXY
104         proxy_scgi:PROXY
105         proxy_wstunnel:PROXY
106         socache_shmcb:SSL
107         ssl:SSL
108         status:STATUS
109         suexec:SUEXEC
110         userdir:USERDIR
111 "
112
113 # critical modules for the default config
114 MODULE_CRITICAL="
115         authn_core
116         authz_core
117         authz_host
118         dir
119         mime
120         unixd
121 "
122 inherit eutils apache-2 systemd toolchain-funcs
123
124 DESCRIPTION="The Apache Web Server"
125 HOMEPAGE="https://httpd.apache.org/"
126
127 # some helper scripts are Apache-1.1, thus both are here
128 LICENSE="Apache-2.0 Apache-1.1"
129 SLOT="2"
130 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
131
132 DEPEND+="apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )"
133
134 REQUIRED_USE="apache2_modules_http2? ( ssl )"
135
136 pkg_setup() {
137         # dependend critical modules which are not allowed in global scope due
138         # to USE flag conditionals (bug #499260)
139         use ssl && MODULE_CRITICAL+=" socache_shmcb"
140         use doc && MODULE_CRITICAL+=" alias negotiation setenvif"
141         apache-2_pkg_setup
142 }
143
144 src_configure() {
145         # Brain dead check.
146         tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
147
148         apache-2_src_configure
149 }
150
151 src_compile() {
152         if tc-is-cross-compiler; then
153                 # This header is the same across targets, so use the build compiler.
154                 pushd server >/dev/null
155                 emake gen_test_char
156                 tc-export_build_env BUILD_CC
157                 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
158                         gen_test_char.c -o gen_test_char $(apr-1-config --includes) || die
159                 popd >/dev/null
160         fi
161
162         default
163 }
164
165 src_install() {
166         apache-2_src_install
167         for i in /usr/bin/{htdigest,logresolve,htpasswd,htdbm,ab,httxt2dbm}; do
168                 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
169         done
170         for i in /usr/share/man/man8/{rotatelogs.8,htcacheclean.8}; do
171                 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
172         done
173         for i in /usr/share/man/man1/{logresolve.1,htdbm.1,htdigest.1,htpasswd.1,dbmmanage.1,ab.1}; do
174                 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
175         done
176         for i in /usr/sbin/{checkgid,fcgistarter,htcacheclean,rotatelogs}; do
177                 rm "${ED}/"$i || die "Failed to prune apache-tools bits"
178         done
179
180         # install apxs in /usr/bin (bug #502384) and put a symlink into the
181         # old location until all ebuilds and eclasses have been modified to
182         # use the new location.
183         local apxs="/usr/bin/apxs"
184         cp "${S}"/support/apxs "${ED%/}/${apxs}" || die "Failed to install apxs"
185         ln -s ../bin/apxs "${ED%/}/usr/sbin/apxs" || die
186         chmod 0755 "${ED%/}${apxs}" || die
187
188         # Note: wait for mod_systemd to be included in some forthcoming release,
189         # Then apache2.4.service can be used and systemd support controlled
190         # through --enable-systemd
191         systemd_newunit "${FILESDIR}/apache2.2-hardened.service" "apache2.service"
192         systemd_dotmpfilesd "${FILESDIR}/apache.conf"
193         #insinto /etc/apache2/modules.d
194         #doins "${FILESDIR}/00_systemd.conf"
195
196         # Install http2 module config
197         insinto /etc/apache2/modules.d
198         doins "${FILESDIR}"/41_mod_http2.conf
199 }
200
201 pkg_postinst() {
202         apache-2_pkg_postinst || die "apache-2_pkg_postinst failed"
203         # warnings that default config might not work out of the box
204         for mod in $MODULE_CRITICAL; do
205                 if ! use "apache2_modules_${mod}"; then
206                         echo
207                         ewarn "Warning: Critical module not installed!"
208                         ewarn "Modules 'authn_core', 'authz_core' and 'unixd'"
209                         ewarn "are highly recomended but might not be in the base profile yet."
210                         ewarn "Default config for ssl needs module 'socache_shmcb'."
211                         ewarn "Enabling the following flags is highly recommended:"
212                         for cmod in $MODULE_CRITICAL; do
213                                 use "apache2_modules_${cmod}" || \
214                                         ewarn "+ apache2_modules_${cmod}"
215                         done
216                         echo
217                         break
218                 fi
219         done
220         # warning for proxy_balancer and missing load balancing scheduler
221         if use apache2_modules_proxy_balancer; then
222                 local lbset=
223                 for mod in lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat; do
224                         if use "apache2_modules_${mod}"; then
225                                 lbset=1 && break
226                         fi
227                 done
228                 if [ ! ${lbset} ] ; then
229                         echo
230                         ewarn "Info: Missing load balancing scheduler algorithm module"
231                         ewarn "(They were split off from proxy_balancer in 2.3)"
232                         ewarn "In order to get the ability of load balancing, at least"
233                         ewarn "one of these modules has to be present:"
234                         ewarn "lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat"
235                         echo
236                 fi
237         fi
238 }