www-servers/apache: arm stable, bug #662894
[gentoo.git] / www-servers / apache / apache-2.2.34.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # latest gentoo apache files
7 GENTOO_PATCHSTAMP="20170918"
8 GENTOO_DEVELOPER="whissi"
9 GENTOO_PATCHNAME="gentoo-apache-2.2.34"
10
11 # IUSE/USE_EXPAND magic
12 IUSE_MPMS_FORK="itk peruser prefork"
13 IUSE_MPMS_THREAD="event worker"
14
15 IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
16 authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
17 authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
18 charset_lite cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio
19 env expires ext_filter file_cache filter headers ident imagemap include info
20 log_config log_forensic logio mem_cache mime mime_magic negotiation proxy
21 proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi rewrite
22 reqtimeout setenvif speling status substitute unique_id userdir usertrack
23 version vhost_alias"
24 # The following are also in the source as of this version, but are not available
25 # for user selection:
26 # bucketeer case_filter case_filter_in echo http isapi optional_fn_export
27 # optional_fn_import optional_hook_export optional_hook_import
28
29 # inter-module dependencies
30 # TODO: this may still be incomplete
31 MODULE_DEPENDS="
32         dav_fs:dav
33         dav_lock:dav
34         deflate:filter
35         disk_cache:cache
36         ext_filter:filter
37         file_cache:cache
38         log_forensic:log_config
39         logio:log_config
40         mem_cache:cache
41         mime_magic:mime
42         proxy_ajp:proxy
43         proxy_balancer:proxy
44         proxy_connect:proxy
45         proxy_ftp:proxy
46         proxy_http:proxy
47         proxy_scgi:proxy
48         substitute:filter
49 "
50
51 # module<->define mappings
52 MODULE_DEFINES="
53         auth_digest:AUTH_DIGEST
54         authnz_ldap:AUTHNZ_LDAP
55         cache:CACHE
56         dav:DAV
57         dav_fs:DAV
58         dav_lock:DAV
59         disk_cache:CACHE
60         file_cache:CACHE
61         info:INFO
62         ldap:LDAP
63         mem_cache:CACHE
64         proxy:PROXY
65         proxy_ajp:PROXY
66         proxy_balancer:PROXY
67         proxy_connect:PROXY
68         proxy_ftp:PROXY
69         proxy_http:PROXY
70         ssl:SSL
71         status:STATUS
72         suexec:SUEXEC
73         userdir:USERDIR
74 "
75
76 # critical modules for the default config
77 MODULE_CRITICAL="
78         authz_host
79         dir
80         mime
81 "
82
83 inherit apache-2 systemd toolchain-funcs
84
85 DESCRIPTION="The Apache Web Server"
86 HOMEPAGE="https://httpd.apache.org/"
87
88 # some helper scripts are Apache-1.1, thus both are here
89 LICENSE="Apache-2.0 Apache-1.1"
90 SLOT="2"
91 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
92 IUSE=""
93
94 src_configure() {
95         # Brain dead check.
96         tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
97
98         apache-2_src_configure
99 }
100
101 src_install() {
102         apache-2_src_install
103
104         # install apxs in /usr/bin (bug #502384) and put a symlink into the
105         # old location until all ebuilds and eclasses have been modified to
106         # use the new location.
107         local apxs_dir="/usr/bin"
108         dodir ${apxs_dir}
109         mv "${D}"/usr/sbin/apxs "${D}"${apxs_dir} || die
110         ln -s ../bin/apxs "${D}"/usr/sbin/apxs || die
111
112         systemd_newunit "${FILESDIR}/apache2.2.service" "apache2.service"
113         systemd_dotmpfilesd "${FILESDIR}/apache.conf"
114 }