sys-apps/xdg-desktop-portal: Drop bogus econf arg
[gentoo.git] / www-plugins / passff / passff-1.9.1.ebuild
1 # Copyright 2018-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_XPINAME="${P}-fx"
7
8 DESCRIPTION="zx2c4 pass manager extension for Firefox"
9 HOMEPAGE="https://github.com/passff/passff"
10 SRC_URI="https://addons.mozilla.org/firefox/downloads/file/3051801/${MY_XPINAME}.xpi"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="www-plugins/passff-host[firefox]"
18
19 S="${WORKDIR}"
20
21 src_unpack() {
22         cp "${DISTDIR}/${MY_XPINAME}.xpi" . || die
23 }
24
25 src_install() {
26         # See https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/Distribution_options/Sideloading_add-ons#Installation_using_the_standard_extension_folders
27         insinto "/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/"
28         # passff@invicem.pro is the extension id found in the manifest.json
29         newins "${MY_XPINAME}.xpi" "passff@invicem.pro.xpi"
30 }