sys-kernel/gentoo-sources: Linux patch 5.0.3
[gentoo.git] / www-misc / profile-sync-daemon / profile-sync-daemon-6.31.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit versionator
7
8 DESCRIPTION="Symlinks and syncs browser profile dirs to RAM."
9 HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
10
11 SRC_URI="https://github.com/graysky2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 KEYWORDS="amd64 x86"
13
14 LICENSE="MIT"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         app-shells/bash
20         net-misc/rsync[xattr]
21         sys-apps/systemd"
22
23 pkg_postinst() {
24         local replacing
25         for replacing in ${REPLACING_VERSIONS}; do
26                 if [[ "$(get_major_version ${replacing})" == "5" ]]; then
27                         ewarn "${PN}-6 and later dropped OpenRC and /etc/psd.conf support"
28                         ewarn "See https://github.com/graysky2/profile-sync-daemon#note-for-version-6"
29                         break
30                 fi
31         done
32 }