dev-qt/qtwayland: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / www-misc / multisort / multisort-1.1-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Merges httpd logfiles in the Common Log Format"
9 HOMEPAGE="https://www.xach.com/multisort/"
10 SRC_URI="https://www.xach.com/${PN}/${PN}-${PV}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 src_prepare() {
18         default
19         # respect LDFLAGS wrt bug #337359
20         sed -i -e 's/$(CFLAGS)/& \$(LDFLAGS)/' Makefile || die 'sed on Makefile failed'
21 }
22
23 src_compile() {
24         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
25 }
26
27 src_install() {
28         dosbin multisort
29 }