e563bc99f5a373bbf1ff87160ef51c695b5855ce
[gentoo.git] / www-misc / buku / buku-3.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit bash-completion-r1 distutils-r1
9
10 DESCRIPTION="Powerful command-line bookmark manager"
11 HOMEPAGE="https://github.com/jarun/Buku"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
22         dev-python/cryptography[${PYTHON_USEDEP}]
23         >=dev-python/urllib3-1.13.1[${PYTHON_USEDEP}]
24 "
25
26 DEPEND="${RDEPEND}
27         test? (
28                 dev-python/flake8[${PYTHON_USEDEP}]
29                 dev-python/hypothesis[${PYTHON_USEDEP}]
30                 dev-python/py[${PYTHON_USEDEP}]
31                 dev-python/pytest[${PYTHON_USEDEP}]
32                 dev-python/pytest-catchlog[${PYTHON_USEDEP}]
33         )
34 "
35
36 python_install_all() {
37         distutils-r1_python_install_all
38
39         insinto /usr/share/zsh/site-functions
40         doins auto-completion/zsh/_*
41
42         newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
43
44         doman buku.1
45 }
46
47 python_test() {
48         py.test -v tests/test_* || die
49 }