41c97b138b4023cfc555a76f509bf9e2412954bc
[gentoo.git] / www-client / pybugz / pybugz-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python3_{6,7} )
6 PYTHON_REQ_USE="readline(+)"
7
8 if [ "${PV}" = "9999" ]; then
9         EGIT_REPO_URI="https://github.com/williamh/pybugz.git"
10         inherit git-r3
11 else
12         SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
14         inherit vcs-snapshot
15 fi
16
17 inherit bash-completion-r1 distutils-r1
18
19 DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
20 HOMEPAGE="https://github.com/williamh/pybugz"
21 LICENSE="GPL-2"
22 SLOT="0"
23 IUSE="zsh-completion"
24
25 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
26 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
27
28 python_install_all() {
29         distutils-r1_python_install_all
30         newbashcomp contrib/bash-completion bugz
31
32         if use zsh-completion ; then
33                 insinto /usr/share/zsh/site-functions
34                 newins contrib/zsh-completion _pybugz
35         fi
36 }