*/*: Bump copyright on files touched this year
[gentoo.git] / www-client / dillo / dillo-3.0.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils multilib toolchain-funcs
6
7 DESCRIPTION="Lean FLTK based web browser"
8 HOMEPAGE="https://www.dillo.org/"
9 SRC_URI="https://www.dillo.org/download/${P}.tar.bz2
10         mirror://gentoo/${PN}.png"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm hppa ~mips ppc ppc64 sparc x86"
15 IUSE="doc +gif ipv6 +jpeg +png ssl"
16
17 RDEPEND="
18         >=x11-libs/fltk-1.3
19         sys-libs/zlib
20         jpeg? ( virtual/jpeg:0 )
21         png? ( >=media-libs/libpng-1.2:0 )
22         ssl? ( dev-libs/openssl:0= )
23 "
24 DEPEND="
25         ${RDEPEND}
26         doc? ( app-doc/doxygen )
27 "
28
29 src_prepare() {
30         epatch "${FILESDIR}"/${PN}2-inbuf.patch
31 }
32
33 src_configure() {
34         econf  \
35                 $(use_enable gif) \
36                 $(use_enable ipv6) \
37                 $(use_enable jpeg) \
38                 $(use_enable png) \
39                 $(use_enable ssl) \
40                 --docdir="/usr/share/doc/${PF}"
41 }
42
43 src_compile() {
44         emake AR=$(tc-getAR)
45         if use doc; then
46                 doxygen Doxyfile || die
47         fi
48 }
49
50 src_install() {
51         dodir /etc
52         default
53
54         use doc && dohtml html/*
55         dodoc AUTHORS ChangeLog README NEWS
56         dodoc doc/*.txt doc/README
57
58         doicon "${DISTDIR}"/${PN}.png
59         make_desktop_entry ${PN} Dillo
60 }
61
62 pkg_postinst() {
63         elog "Dillo has installed a default configuration into /etc/dillo/dillorc"
64         elog "You can copy this to ~/.dillo/ and customize it"
65 }