www-apps/gitea: Version bump to 1.1.1
[gentoo.git] / www-apps / pcgi / pcgi-2.0_alpha5.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 # this package is ONLY available inside the Zope tarball!!!
5 ZOPE_PV=2.6.1
6 ZOPE_P=Zope-${ZOPE_PV}-src
7 S="${WORKDIR}/${ZOPE_P}/pcgi"
8
9 # the only real docs about it are on the author's homepage
10 # the html.bz2 file is a copy of http://starship.python.net/crew/jbauer/persistcgi/howto/index.html, renamed.
11 # this is specifically done as every link I have seen is to the old URL of the
12 # author
13 DOCDATE="1998-08-13"
14
15 MY_PV="${PV/_alpha/a}"
16
17 DESCRIPTION="Jeff Bauer's Persistent CGI"
18 HOMEPAGE="http://starship.python.net/crew/jbauer/persistcgi/"
19 SRC_URI="http://www.zope.org/Products/Zope/${ZOPE_PV}/${ZOPE_P}.tgz
20                  mirror://gentoo/PCGI-HOWTO-${DOCDATE}.html.bz2"
21 LICENSE="ZPL"
22 SLOT="0"
23 KEYWORDS="~x86 ~ppc"
24 IUSE=""
25 DEPEND="${DEPEND}"
26 RDEPEND="${RDEPEND}
27         dev-lang/python"
28
29 src_compile() {
30         econf || die "econf failed"
31         emake all creosote || die "emake failed"
32 }
33
34 src_install() {
35         into /usr
36         dodir /usr/bin
37         dodoc ${WORKDIR}/CGI-HOWTO-1998-08-13.html
38         newbin pcgi-wrapper pcgi-wrapper${MY_PV}
39         dosym /usr/bin/pcgi-wrapper${MY_PV} /usr/bin/pcgi-wrapper
40         dodoc MrCreosote/README.MrCreosote README Test/README.parseinfo
41         newdoc Util/README README.Util
42         dobin MrCreosote/pcgi-creosote MrCreosote/creosote.py
43         dobin Util/killpcgi.py Util/pcgifile.py
44         dobin pcgi_publisher.py
45         newbin Test/parseinfo pcgi-parseinfo
46         cp -pPR Example ${D}/usr/share/doc/${PF}/
47 }