media-libs/lsp-plugins: cairo needs the X flag
[gentoo.git] / www-apps / liquid_feedback_core / liquid_feedback_core-3.0.4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit eutils toolchain-funcs
7
8 MY_P=${PN}-v${PV}
9
10 DESCRIPTION="Internet platforms for proposition development and decision making"
11 HOMEPAGE="http://www.public-software-group.org/liquid_feedback"
12 SRC_URI="http://www.public-software-group.org/pub/projects/liquid_feedback/backend/v${PV}/${MY_P}.tar.gz"
13
14 LICENSE="HPND CC-BY-2.5"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19 RDEPEND="dev-db/postgresql"
20 DEPEND="${RDEPEND}"
21
22 S=${WORKDIR}/${MY_P}
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${PN}-3.0.4-gentoo.patch
26 }
27
28 src_compile() {
29         emake \
30                 CC="$(tc-getCC)" \
31                 CFLAGS="${CFLAGS}" \
32                 CPPFLAGS="-I $(pg_config --includedir)" \
33                 LDFLAGS="${LDFLAGS} -L $(pg_config --libdir)"
34 }
35
36 src_install() {
37         dobin lf_update lf_update_suggestion_order lf_export
38         insinto /usr/share/${PN}
39         doins -r {core,init,demo,test}.sql update
40         dodoc README "${FILESDIR}"/postinstall-en.txt
41 }