1966b9410b745d4ad8a0a41dc5278a1b7984e2de
[gentoo.git] / www-apps / klaus / klaus-1.5.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A simple, easy-to-set-up Git web viewer"
11 HOMEPAGE="https://github.com/jonashaag/klaus/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="ISC"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="ctags"
18
19 RDEPEND="
20         >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
21         dev-python/flask[${PYTHON_USEDEP}]
22         dev-python/httpauth[${PYTHON_USEDEP}]
23         dev-python/humanize[${PYTHON_USEDEP}]
24         dev-python/pygments[${PYTHON_USEDEP}]
25         dev-python/six[${PYTHON_USEDEP}]
26         ctags? ( dev-python/python-ctags[${PYTHON_USEDEP}] )
27 "
28 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
29
30 # The tests can only be run from a git repository
31 # so they are not included in the source distributions
32
33 python_install_all() {
34         distutils-r1_python_install_all
35         doman ${PN}.1
36 }