www-apps/owncloud: 10.0.7 bump
[gentoo.git] / www-apps / icingaweb2-module-director / icingaweb2-module-director-1.1.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Icinga Web 2 plugin for configuration"
7 HOMEPAGE="https://dev.icinga.org/projects/icingaweb2-module-director/"
8 if [[ "${PV}" == 9999 ]]; then
9         inherit git-r3
10         EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-director.git"
11 else
12         KEYWORDS="~amd64 ~x86"
13         MY_PN="icingaweb2-module-director"
14         SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
15         S="${WORKDIR}/${MY_PN}-${PV}"
16 fi
17
18 LICENSE="GPL-2"
19 SLOT="0"
20
21 DEPEND=">=net-analyzer/icinga2-2.4.3
22         >=www-apps/icingaweb2-2.2.0
23         || (
24                 dev-lang/php:5.6[curl]
25                 dev-lang/php:7.0[curl]
26         )"
27 RDEPEND="${DEPEND}"
28
29 src_install() {
30         insinto "/usr/share/icingaweb2/modules/director/"
31         doins -r "${S}"/*
32 }