app-editors/nano: Added USE="minimal" build fix.
[gentoo.git] / www-apps / curator / curator-3.0_p20110120-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit python-single-r1
9
10 DESCRIPTION="Gallery generator"
11 HOMEPAGE="http://furius.ca/curator/"
12 SRC_URI="mirror://gentoo/curator-3.0_pf078f1686a78.tar.xz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~hppa ~mips ppc x86"
17 IUSE=""
18
19 DEPEND=""
20 RDEPEND="${DEPEND}
21         ${PYTHON_DEPS}
22         dev-python/pillow[${PYTHON_USEDEP}]
23         virtual/imagemagick-tools"
24
25 REQUIRED_USE=${PYTHON_REQUIRED_USE}
26
27 S="${WORKDIR}/curator-3.0_pf078f1686a78"
28
29 src_compile() {
30         python_fix_shebang hs/curator-hs
31 }
32
33 src_install() {
34         dobin hs/curator-hs
35         insinto /usr/share/curator
36         doins -r hs
37 }