Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / www-apache / mod_wsgi / mod_wsgi-3.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
8 PYTHON_REQ_USE="threads"
9
10 inherit apache-module eutils python-single-r1
11
12 DESCRIPTION="An Apache2 module for running Python WSGI applications"
13 HOMEPAGE="https://code.google.com/p/modwsgi/"
14 SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 KEYWORDS="amd64 ppc x86"
19 IUSE=""
20
21 DEPEND=""
22 RDEPEND=""
23
24 APACHE2_MOD_CONF="70_${PN}"
25 APACHE2_MOD_DEFINE="WSGI"
26
27 DOCFILES="README"
28
29 need_apache2
30
31 src_configure() {
32         econf --with-apxs=${APXS} --with-python=${PYTHON}
33 }
34
35 src_compile() {
36         default
37 }